官方圈
分享
  • 收藏
    X
    在今天518这个特别的日子里,我们经过将近一年来,日以继夜努力研发出的X1正式对外公开发布!
    3973
    75

    前言:我们是技术宅男,只会低头做事,不像搞市场营销的,所以我们不搞华丽的发布会,确切的说,我们也没有那样的闲钱去做表面工作.我们只懂继续埋头完善程序.


    程序下载地址:


    本站下载:  http://www.php168.com/x1.zip


    第三方站点下载  https://gitee.com/qibosoft/x1_of_cms


    PHP高版本环境下载: http://phpstudy.php.cn/


    提示:程序会频繁更新,在码云那里会有部分更日志,即使你下载的程序还没得到及时更新,但你安装以后,可以在后台一键同步升级到最新版,而不必担心你下载的是不是最新的程序。同时也请大家在码云右上角点个Star以支持我们.


    齐博X1.0的特色在哪?


    基于最新的thinkphp5框架,可以运行在最新的PHP7环境下。这当然不是我们的特色所在,因为市场面基于TP框架开发的系统多如牛毛,数都数不清。


    正如那首歌所唱的,我们不一样!我们不一样,主要体现在以下方面:


    齐博标签

    这可是我们的最大特色,从十多年前V系列开始,就一直被用户津津乐道,在这一次,我们又进行了重大升级,无论是前台,还是会员中心,都可以通过标签轻松调用网站的常用数据。

    当然这不仅仅是简单的调用显示,更重要的是可以很方便的实现JQ加载,也即所谓的无刷新调用显示更新。在过去,包括现在很多同行,想要做JQ异步加载,每一处都要另外的写PHP代码,即使不用写代码,那也要另外单独写前端展现html的JS内容代码。而借助我们的齐博标签,这一切都可以省略。

    所以我们可以很自信的对外说,在前端页面制作的数据灵活性调用方面,目前市场面还没有哪一家做得比我们更好的,前台所有内容都可以通过标签设置。(当然这跟那种拖拽显示的是两码事,那种是表面灵活,实际是受框架制约的。)

    如果你要做PC或者WAP展示性的网站,选择我们,绝对会令你爱不释手。



    在线安装与在线升级功能

    这一次,我们把在线安装与在线升级做到了的极致,首先,系统无论是文件,还是数据库的升级,都是在后台可以一键同步升级,并且可以有选择性的升级哪些文件,当然你不想升级的某些文件,可以做个标志,以后就不会提示升级。其次,所有模块都是在后台的云端市场在线安装,再次,所有模块与插件,也都可以在后台同步升级。

    这在过去,包括现在很多同行,要么就要手工升级,要么就不能做到全智能的在线同步安装与升级。


    云市场

    这一次,我们提供了丰富的云市场,功能最大的就是模块市场,然后就是插件市场,功能最小的,小到一个文件的钩子也提供了云市,当然风格也有云市场。基于云市场,才能实现一个良性的循环,开发者可以有适当的收益,才能持久的升级与开发维护。


    模块可复制

    我们系统里边的模块都是可以在后台一键复制,便可以很方便的实现二次开发,当然部分插件也是可以一键复制。如此轻松简单的把频道复制,这个在当前市场上来说,还是极少见的。



    强大灵活的CMS核心

    经过10多年的CMS开发经验,总结出当前内容管理系统常用的核心功能,提炼出C.php F.php S.php M.php这几个文件,作为所有模块二次开发的基础,大大减轻了二次开发的工作量。


    强大的APP与小程序接口

    基于标签,提供非常丰富的APP与小程序数据调用接口,后台可以随时改变APP与小程序的数据显示方式。


    WAP与PC端自适应

    基于同一个PHP文件,可以实现WAP与手机端的功能,模板可以自适应,你可以分别做两套模板,他会自动调取。(如果你想PC与WAP不同的域名也是可以的)


    完善的基础框架

    系统默认提供了QQ登录、微信登录、小程序登录,支付宝及小程序及微信支付接口。同时也提供了扩展性非常灵活的公众号接口。当然还有最常用的邮箱及短信及第三方存储。



    用一句话来总结:这一次,我们通过核心+模块+插件+钩子的理念把系统的灵活性及拓展性做到了极致!!





    35
    打赏
    收藏
    点击回复
        全部留言
    • 75
    • 但求一富@MARK 普通会员 2天前2楼

      我看X1的ThinkPHP版本还是5.0.18,官方最新推荐为5.0.20,请问什么时候升级下,另有计划更换TP5.1吗?还有个问题,为什么模块都的控制器都不带Controller的,不像是TP的基因呐。

    • kekeyffs 普通会员 2个月前3楼

      我下载了就是安装时出问题,测试连接数据库也成功,为什么执行安装时出现这个PHP是7.0.3,数据库是5.7.11版,我的环境装织梦,dz都没有问题,如果解决

      cxh50988 2个月前
      我的腾讯云空间,今天安装也出现同样的问题,有20几个表写入成功
      kekeyffs 2个月前
      你的也出现这个问题?
      kekeyffs 2个月前
      我换低版本的数据库可以安装
      数据库5.7.11会出现问题,在论坛上也有一个人也遇到了我同样的问题
      zhlslyw 1个月前
      这两天安装不了,同样出现这样的情况。
      zhlslyw 1个月前

      安装难,如果有V7  V9  V1.0那么简单就好了,

      Szup.com乐刷朱弟 1个月前
      安装都不会安装,你不要用齐博,谢谢
      qiheng 1个月前
      Szup.com乐刷朱弟 6天前安装都不会安装,你不要用齐博,谢谢
      这说明什么?? 问题多么??
      Livens(绿雨) 26天前
      我也是这个问题,自己的服务器上(ubuntu-server16.04, 64bit),mysql Ver 14.14 Distrib 5.7.22, for Linux (x86_64) using EditLine wrapper。
    • 小君阁-1 普通会员 1个月前9楼

      测试数据库正常   导入数据库就没反应啦

      admin 1个月前
      私信发FTP过来.帮你检查一下
      数据库版本的问题
    • 深蓝 普通会员 1个月前2楼

      好久没来齐博了,居然不知道齐博已经使用tp框架了,早该用了!祝贺一下

    • wmanor 普通会员 1个月前3楼

      09年就接触php168的老用户特意注册个新号过来顶一下

      gesy888 1个月前
      我是07年~~
    • 祯禛 普通会员 1个月前2楼

      支持

    • 纬创网络科技 普通会员 1个月前3楼
      等了好久了,终于可以下载,强烈支持一下!!!!!
    • cqps 普通会员 1个月前4楼

      好样的

    • 华桥 普通会员 2个月前6楼
      老大,出个像齐博V7那样的,本地一健安装啊,我搞了半天,都提示版本不对,PHP至少要5.5以上,如果出个一健安装包更易上手,可以先在本地测试练手
      qiqi123 1个月前
      下载个PHPSTUDY,然后选择PHP为5.6就行了
    • qiqi123 普通会员 1个月前2楼

      这个云码让人非常的恼火,使用QQ登录了,还要绑什么帐号,搞得这么麻烦,注册都注不成功,下载不了,谁有的给我一份得了

    更多回复